ブログをつくる(WordPress)

自作アプリケーション用にAWSでWebサーバーを立てているけども有効活用できていないのでブログをつくってみる。

基本的に公式のドキュメントを参考に進めてみる。


環境

環境は以下。

  • CentOS 6
  • Apache 2.2
  • MySQL 5.1
  • PHP 5.3

↑はすでにインストール済み。

WordPress日本語版の推奨動作環境は満たしていない。

公式サイトには怖い感じで書かれているけど、yumコマンドでインストール&アップデートしているので良しとする(*)。

WordPress 日本語版の動作環境

  • PHP バージョン 5.6 以上推奨
  • MySQL バージョン 5.5 以上推奨

古い PHP や MySQL しか利用できないレガシーな環境でも、PHP 5.2.4 以上、かつ MySQL 5.0 以上であれば WordPress は動作しますが、公式なサポートが終了しているため、サイトがセキュリティの脆弱性にさらされる危険性を理解したうえで利用してください。

WordPress › 日本語

(*)安全なPHPを使っていますか? – PHPバージョンアップとの付き合い方を考える

・・・ここまでは2015年11月に書かれたものです。

別のことが気になってそこで手が止まってしまいました。

ここから先はできる限り思い出した手順です。

・・・現在思い出し中

インストール

テーマ

  • Simplicity

プラグイン

  • Akismet
  • Crayon Syntax Highlighter
  • SiteGuard WP Plugin
  • Table of Contents Plus
  • WP Multibyte Patch

その他設定など

  • サイドバーウィジェットから「メタ情報」を削除